Showing results for 
Search instead for 
Did you mean: 

Oculus Quest 2 guardian floor bug.

Level 3
Floor level in games with the oculus quest 2 is NOT correct and makes a huge problem in all games. I find I am about 10cm off from my real height (to tall) and makes gameplay not work in most games correctly. Beat saber notes appear too low and you have to eyeball both a floor offset and manually set your height to fix the notes. It doesn't feel 100% right and you can't judge proper height or depth due to the platform not having texture for you to perceive depth. 

In 11 table tennis you can set the floor within the game (same as you do with the guardian) and it visually shows the difference between floor height and real height.

A lot of users are having this issue and setting controller on the ground does not behave as expected when setting guardian. It's hard to tell that it's wrong until you play games and many are probably not sensitive to the issue. 

Is this due to the new cameras having a different focal length and this just needs a calibration?

Level 2

Just started the headset up to find the same problem.  Had it for under a year, first problem.

Hey there, we completely understand your frustrations with this. Make sure the USB is plugged into a USB3 Port as recommended. ( Often indicated as the blue port, however, others may color these ports differently. Safe bet, it's the non-white/black port. Also, make sure that the play area is well lit. If you are still having issues you can check the settings, and Reset Guardian. If you wouldn't mind, you could also send us a private message here. That way we could gather some more information from you. Or, you can submit a support ticket on our website HERE. We offer email and chat support, there one of our agents would be more than happy to assist you with this. Don't hesitate to reach out to us for assistance, we're always here to help. 

I have a lot of problems with Guardian as well, though a combination of restarts/recalibrations usually clears it up.  


In one case I was floating over the ground because of a Skyrim VR Mod (VRIK), and the changes that mod made persisted through other games.  Restarting the headset fixed it.  I have started using Sidequest, which gives a little more control over advanced system settings on the fly.    

Level 2

This would be an easy fix if there was a way to manually adjust the height settings. Just like others here in this thread, it worked for a few days then all of a sudden now I'm 8feet tall and my feet are not on the ground. When I'm playing Fallout VR im towering over the npcs,  almost as tall as deathclaw. There is a height setting in the game that lowered me a little but not much. There needs to be more manual settings. I even think PSVR has that 

Level 3

My Oculus Quest 2 has become useless....  I don't think a factory reset is a valid solution when it erases all your progress without backing everything up on Sidequest and praying it can be restored.  It's not a solution for regular Metaverse people and I don't want to do it.  

When I try to setup a guardian, pluses move around.  I move my head and the pluses move.  I reach down to set the floor height and stand up and the pluses float.  Rooms, lights, lenses, reboots, software updates, everything short of a factory reset does nothing.  And I'm betting a factory reset won't help.  

The point is that the apps work fine.  The floor is just in the wrong place.  Setting up the guardian is the problem! When will this get fixed for ALL users???

None of this helps...  When I go to set the guardian, the pluses move around with my head.  The pluses sink when I get close to the floor and touch the controllers to the ground and then float back up when I stand up.  They are NOT syncing with the external world AT ALL!  Even though once I've setup the guardian even though it's messed up, the applications play just fine (WITH THE WRONG HEIGHT!!!).  I've tried every solution except factory reset, because a factory reset is an unacceptable solution.  Obliterating all your user data is NOT how the Metaverse is supposed to work...  😞  Don't try blaming Android or App Developers.  This is Oculus'/Meta's responsibility.  FIX IT!!!

Same problem. Started happening 3 nights ago. I hope it's a software/firmware issue that will get fixed soon!


Level 3

Mine started acting up today after updating to the latest firmware update. I started my quest 2 after the update finished installing. Moved to a different spot and reset my stationary boundary to the new spot, everything froze and then the home theme wouldn’t load. Restarted. And bam. Floating floor. I can’t lock it to the correct floor level. 
it just floats up towards my waist level no matter what I do. 

this happened once before Also while a major update was rolling out… so I think it’s related.  I tried resetting clearing guardian etc and no luck. The only thing that worked last time was waiting for updates and eventually one of them fixed it. It took 2-4 weeks

Level 2

I was able to fix this by the following process:

  • Clear all guardian info
  • Go to dev settings, see Google for info on enabling dev mode. 
  • Turn OFF the guardian
  • Reboot
  • Go back to dev settings and turn the guardian back on
  • Create a new guardian
  • Dance happily

I gave this a shot just now and unfortunately the floor still won’t lock to the ground, it floats waist level and is tilted slightly… I have an update pending so fingers crossed this fixes it. If not I have no idea what else to do since last time it corrected on its own.