cancel
Showing results for 
Search instead for 
Did you mean: 

Quest Link Issue on quest 2. Can anyone help with this?

xXNoviaXx
Level 3
I recently bought the hp omen 2020 gaming laptop so that I would have a vr ready pc to play games on my oculus quest 2. I have Nvidia Geforce GTX 1160 Ti so it meets the requirements for the quest. Whenever I link my quest to my pc and click a game such as vrchat, my quest shows me in a white room with a screen in front of me with the vrchat logo and says either waiting or loading but the game is on my pc monitor tracking and showing what should be coming from my headset. The screen never does load into my headset. After trying to play through steamvr it just tells me that my headset is not connected to the same video card as my monitor. I'm also using the official quest link cable. Is there anyway I can fix this? I feel like i've tried everything with no solution. 😞
22 REPLIES 22

xXNoviaXx
Level 3
I should also add that I just got the quest 2 yesterday so everything should be updated.

PITTCANNA
Level 13
Disable the internal graphics from the Intel cpu in the device manager.  Then open the nvidia graphics manager and put everything oculus and steam vr on the gtx 1160.

TomCgcmfc
Level 15

xXNoviaXx said:

I recently bought the hp omen 2020 gaming laptop so that I would have a vr ready pc to play games on my oculus quest 2. I have Nvidia Geforce GTX 1160 Ti so it meets the requirements for the quest. Whenever I link my quest to my pc and click a game such as vrchat, my quest shows me in a white room with a screen in front of me with the vrchat logo and says either waiting or loading but the game is on my pc monitor tracking and showing what should be coming from my headset. The screen never does load into my headset. After trying to play through steamvr it just tells me that my headset is not connected to the same video card as my monitor. I'm also using the official quest link cable. Is there anyway I can fix this? I feel like i've tried everything with no solution. 😞


Laptops are often pretty finicky to get working in PCVR and you are best to avoid using these so-called VR ready laptops imho.  Also, keep in mind that laptop mobile gpu's have much less power than their desktop equivalent (~20% difference in your case).

The usual problem is that you have an internal integrated igpu (probably intel) and an internal dedicated gpu (your nvidia 1660ti).  What you need to do is go into your nvidia control panel and on 3d settings global tab make sure the top line you select ' use high powered nvidia gpu '.  This normally helps a lot.  Plus, scroll down on the 3d panel and on the power options, select prefer max performance.  

Go to your win10 power plans and select high performance.  Then go to your device manager and under your Universal serial bus controllers, right click on each of these and ones that have a power plan make sure that you disable (uncheck the box) allow it to turn off.

Anyway, hopefully this should get you started.  I realize you are new here but next time maybe spend a little more time reviewing Support and Quest sections of this forum to see if you can find solutions.  Good luck and cheers.
i9 9900k, rtx3090, 32 Gb ram, 1tb ssd, 4tb hdd. xi hero wifi mb, 750w psu, Q2 w/Air Link, Vive Pro

xXNoviaXx
Level 3
The problem with this solution is that when I change my global setting to NVIDIA 1660 Ti, for some reason my oculus link won't work in my headset. When I enable link it just goes into a black screen and stays there in my headset. The only way I can fix this problem is to restore all my settings back to the original settings. I'm Wondering if it has something to do with the fact that when I looked into my NVIDIA control panel it showed AMD as the usb c port and NVIDIA as the other ports. I'm wondering if using a usb c to usb 3 cable would work?tt78111gsala.png

PITTCANNA
Level 13
Like I said before you need to disable the internal graphics and radeon in device manager.

TomCgcmfc
Level 15

PITTCANNA said:

Like I said before you need to disable the internal graphics and radeon in device manager.


Ya, that's probably his next best port of call mate.  Usually nvidia 3d preferences is enough and this is all I needed to do with my Alienware 17r4.  Maybe AMD igpu is different?  I think he also needs to check how his usb link connection is working (link setup usb test).  If he is using a usb3.1 type c port or whether he is using it with a standard usb3 port and maybe try both (adapter may be necessary).  
i9 9900k, rtx3090, 32 Gb ram, 1tb ssd, 4tb hdd. xi hero wifi mb, 750w psu, Q2 w/Air Link, Vive Pro

xXNoviaXx
Level 3
@PITTCANNA after trying this solution by disabling radeon (which I assume are my internal graphics correct me if i'm wrong i'm new to all this computer stuff) I then went into my NVDIA control panel and changed everything Oculus and Steamvr. What I found is that I am unable to open link at all in the quest. When I press to enable link in settings nothing happens and it just brings me back to home.

PITTCANNA
Level 13
Is your usb c a type 3.1? Sometimes laptops cheap out

xXNoviaXx
Level 3
@PITTCANNA My laptop has both but i'm using the official oculus link cord so currently i'm using the usb c port.