cancel
Showing results for 
Search instead for 
Did you mean: 

Unity Editor freezing on window-focus changes in OculusVR 1.17

jaconcha
Level 3
While Oculus VR Runtime Service is running (in Windows Services), changing focus between Editor windows in any Unity project is followed by a 4-10 second freeze of all input.  The sessions appear to be affected regardless size/complexity/version, as I tested on 3 different versions with 3 different active projects and 3 new empty projects (6 total tests)

It seems to only be when you change between windows in the Unity Editor.  If you stay in one window, it's able to run smoothly.  Are there any solutions out there to this?  It's as close to blocking as a blocker can be.  It may also be related to the latest Windows 10 update, since I received both between sessions of Unity work.

But, if I stop OVR Runtime Service, it works like a dream.

Thanks for the help!
43 REPLIES 43

cybereality
Level 15
Moving to Unity dev forum.

Massycat
Level 2
Same is happening for me.
Have tried with multiple projects in various versions of Unity (5.6.3f1 and 5.6.1p1) and the same result of a few seconds pause when clicking from one Unity Editor view to another. For example after manipulating something in the Scene view, if I click on the Inspector view there will be a few seconds pause before Unity responds.
If you look in the Windows Task Manager you can see the Unity process become "Not Responding" just before it recovers. Uninstall the Oculus software fixes the problem but make Oculus development a little tricky.

Massycat
Level 2
Current have Oculus app version 1.17.0.424527 (1.17.0.424315) installed.

jaconcha
Level 3
Not that this absolves Oculus Tech Support in any way, I think this may be Windows 10 Creators Update related.  I got both at the same time, and other people at my studio are not experiencing the same issues with 1.17, but also haven't received the Windows update, yet.

I hope a fix for this is coming soon.

Anonymous
Not applicable
Posted on reddit regarding this, carlsagan79 requested some info to troubleshoot, no word since. Temporary workaround is to disable oculus runtime in Services, and edit in Unity. To
playback in unity, enable in services, wait couple mins, open oculus
desktop + play. Not great timewise, but works till hopefully patched by
oculus.
reddit posts
https://www.reddit.com/r/oculus/comments/6se0qb/unity_editor_freezing_after_rift_117_update/

https://www.reddit.com/r/oculus/comments/6sdf4c/oculus_rift_related_processes_have_started/


Clavus
Level 4
Got the same issue, coincided with updating to the Oculus 1.17 update. Stopping OVRService is a temp fix for now.

rvpeterson
Level 3
Experiencing this same problem. Is there any fix other than stopping and starting the OVRService continiously?

catscratchjohnn
Level 2
Same here. I've been re-installing everything trying to track this one down. Totally unusable on my home computer, though my work computer isn't affected. Stopping the Oculus VR Runtime Service stops the problem

Here is another (Unity) thread talking about it.
http://answers.unity3d.com/questions/1391741/unity-editor-severe-performance-delay-for-most-act.html


My home machine is using the following USB card and drivers

USB 3 PCI X Card (FL1100 chipset)
https://www.inateck.com/inateck-ktu3fr-5o2i-usb-3-0-pci-express-card.html?___SID=U

I can't do any VR development at home. Is there a way to rollback the runtime version?



catscratchjohnn
Level 2
I double posted by accident, but don't see a way to delete. So I'm editing the dupe to ask this question:

What USB controllers are people using?

I bought this new (Inateck/FrescoLogic) USB card because Oculus doesn't support the (Etron) USB controllers on my (Gigabyte) motherboard. The new card has worked fine for the past 6 months, until this update.

Anyone else using the same card or FL1100 series?

iv6bpp4avpz2.jpg