cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot join a session anymore

m_milazzo
Level 4
Since two days I'm not able anymore to join a session. We have a listen server which starts an Oculus session with a valid matchmaking pool and some other clients which search for it and join it.
On the listen server side it correctly creates the session and opens the level with the "?listen" parameter;
On the client side the session is found, when trying to join it succeeds (I see the call to the delegate OnJoinSessionComplete with Success) but then it does not open the level, neither the users can listen one each other.

The only interesting things I see in the log are the following:
[2018.11.08-14.54.52:191][783]VoiceSessionLog: OnJoinSessionComplete: Success
[2018.11.08-14.54.52:191][783]VoiceSessionLog: Registering remote talker 1483781508382744
[2018.11.08-14.54.52:191][783]VoiceSessionLog: Remote talker registered: 1483781508382744

[2018.11.08-14.54.52:192][783]LogNet: Browse: 1483781508382744.oculus//Game/Maps/StartMap

[2018.11.08-14.54.52:192][783]LogTemp: Display: ParseSettings for GameNetDriver

[2018.11.08-14.54.52:192][783]LogTemp: Display: ParseSettings for OculusNetDriver_0

[2018.11.08-14.54.52:192][783]LogTemp: Display: ParseSettings for PendingNetDriver

[2018.11.08-14.54.52:192][783]PacketHandlerLog: Loaded PacketHandler component: Engine.EngineHandlerComponentFactory (StatelessConnectHandlerComponent)

[2018.11.08-14.55.07:825][190]LogVoice: Warning: 1483781508382744 timed out

In these three days we changed nothing, and none of our applications (four apps) works anymore. Did you change something on your side? Do we need to modify the connection some way?

We use UE 4.19.2, the Oculus' version of the engine.

May you help us to investigate? It is an urgent problem.
Thanks


ADDITIONAL DETAILS:
In some previous log files (when it worked) I also see these rows, which now I can't see anymore.

[2018.10.31-15.52.09:625][211]LogHandshake: SendChallengeResponse. Timestamp: 20.742823, Cookie: 255120151072099173030100234249012201097026085177018060056185
[2018.10.31-15.52.09:634][212]LogNet: UPendingNetGame::SendInitialJoin: Sending hello. [UNetConnection] RemoteAddr: 1483781508382744.oculus, Name: OculusNetConnection_0, Driver: PendingNetDriver OculusNetDriver_0, IsServer: NO, PC: NULL, Owner: NULL, UniqueId: INVALID
It seems something goes wrong with the handshake (UPendingNetGame::SendInitialJoin, from code, should be called when the handshake has been completed).
3 REPLIES 3

m_milazzo
Level 4
Hi @imperativity , thanks for helping us.
1. This occurs every time
2. Future connections don't fail (they just behave like the first one, join succeeds but the level is not open)

xN31
Level 4


@ginopeloso

Thanks for the information!

Hi @imperativity , any update on this? we are setting up a demo for an important event next week and we haven't been able to create sessions for several days now. It's very important for us to find a workaround in the next few days.
Does this issue impact all the countries or only specific geographical areas? In our context it seems to be completely deterministic, were you able to replicate the problem? 
Please let me know if we can somehow help or if you have any advice. 

xN31
Level 4
@imperativity Runtime 1.32.0.730459
Ok, great! Everything working again from our first tests 🙂 thank you so much!!