cancel
Showing results for 
Search instead for 
Did you mean: 

Deriving from UE4 OculusHMD module classes such as UOculusBoundaryComponent

Kurodo
Level 2
Hi, 

I want to be able to derive from UOculusBoundaryComponent but the class is declared with the MinimalAPI tag, and without the OCULUSHMD_API macro, which results in linker errors even though I am able to choose the class through the standard UE4 'Create new C++ class' dialogue. 

I can easily dip into the plugin source to change this but I wondered if there was a specific reason why I should not be doing this, or whether there were plans to change the plugin in the future.

thanks.
0 REPLIES 0